Issues with 3rd party service provider causing degrade performance in Offstreet

Incident Report for Offstreet

Postmortem

Incident Report – 21 October 2025

What Happened

On October 21, 2025, at 21:59 UTC, we noticed that Offstreet was running slower than usual. Our team quickly identified that the slowdown was caused by an outage from one of our third-party partners.

We implemented a fix at 22:33 UTC, and the system was back up and running at normal speed shortly after.

Who Was Affected

Both the Offstreet Dashboard and Portal were affected. Users and parkers could still register vehicles and complete actions, but pages took longer to load during the incident. No data was lost.

What Caused It

The slowdown happened because one of our partner services experienced an outage.

What We’re Doing About It

We’ve been working on ways to make Offstreet more resilient to third-party issues, and those improvements helped reduce the impact this time. We’ll continue strengthening these systems so we can keep things running smoothly even if a partner experiences problems in the future.

Moving Forward

Everything is now back to normal, and we’ll keep monitoring to make sure it stays that way.

As always, if you notice anything unusual or have questions, please reach out to our support team.

Thanks for your patience while we worked through this,
The Offstreet Team

Posted Oct 21, 2025 - 17:12 CST

Resolved

Update: Performance Restored

Offstreet was recently affected by an outage from one of our third party partners. We’re really sorry if this caused slower load times or disruptions for you.

The good news: our engineering team has implemented a fix that helps us avoid being impacted by the partner’s outage. Offstreet is back up and running as expected, and we’re continuing to monitor closely.

Thank you for your patience while we worked through this!
Posted Oct 21, 2025 - 16:46 CST

Investigating

The engineering team recently noticed an issue with a third party integration partner that is causing performance issues. You may notice slow loading times.

The engineering team is actively working on deploying a temporary workaround until the integration partner has recovered.

Thank you for your patience as we work to improve system performance!
Posted Oct 21, 2025 - 16:17 CST
This incident affected: Offstreet Portal, Offstreet Dashboard, Offstreet Core, and Offstreet Reporting.